Trying to fix my ZxSpectrum+

For experts to discuss very technical stuff and newbies to ask why the Spectrum they bought off ebay doesn't work.
User avatar
Morkin
Manic Miner
Posts: 605
Joined: Mon Nov 13, 2017 8:50 am
Location: Bristol, UK

Re: Trying to fix my ZxSpectrum+

Post by Morkin » Sun Jun 09, 2019 3:48 pm

1024MAK wrote:
Fri Jun 07, 2019 11:11 am
Other flux types should be cleaned with either flux cleaner, or IPA (the solvent, not the drink).
:lol:
0 x

Hyuma
Berk
Posts: 34
Joined: Sat May 18, 2019 6:43 am

Re: Trying to fix my ZxSpectrum+

Post by Hyuma » Mon Jun 10, 2019 7:36 am

Ok, on the next weeks i'll buy some new equipment to repair this damage. I will keep you informed on how it is proceeding. For now thanks to all! 8-)
0 x

Hyuma
Berk
Posts: 34
Joined: Sat May 18, 2019 6:43 am

Re: Trying to fix my ZxSpectrum+

Post by Hyuma » Mon Jun 17, 2019 10:24 pm

Hi guys, a little update. With a software I designed the lower ram pcb scheme to be sure not to make mistakes later when I try to restore the tracks. Did I do everything right? Thanks in advance for every reply.

Image
0 x

Hyuma
Berk
Posts: 34
Joined: Sat May 18, 2019 6:43 am

Re: Trying to fix my ZxSpectrum+

Post by Hyuma » Mon Jul 01, 2019 3:28 pm

Hey guys, it's been a bit that I didn't update my post. Here some news:


Image

Image

I put all the 7 sockets!!!!! And I'm very proud of me guys!!! Now I've a doubt, I dunno where to solder this pin:


Image it's near the blu capacitor..
1 x

User avatar
DouglasReynholm
Microbot
Posts: 138
Joined: Wed Feb 20, 2019 8:38 pm
Location: Norf Lahndan Innit

Re: Trying to fix my ZxSpectrum+

Post by DouglasReynholm » Mon Jul 01, 2019 6:16 pm

Well while I'm sorry I can't help you much here, as the person that sent you here from another social media site (shhhh!), I'm impressed with the effort you are persisting with to get it fixed.
1 x

Hyuma
Berk
Posts: 34
Joined: Sat May 18, 2019 6:43 am

Re: Trying to fix my ZxSpectrum+

Post by Hyuma » Mon Jul 01, 2019 7:12 pm

I think it should be connected to the pin 14 of IC7, but i'm waiting some confirm! :D
0 x

User avatar
Ast A. Moore
Dynamite Dan
Posts: 1190
Joined: Mon Nov 13, 2017 3:16 pm

Re: Trying to fix my ZxSpectrum+

Post by Ast A. Moore » Mon Jul 01, 2019 7:15 pm

I only have a picture of a populated Issue 6A board, but it’s fairly high resolution. The trace form that via goes up and is likely connected to the via next to Pin 3 under the socket. It’s best to use the schematic and a tester in continuity mode and determine the exact routing by process of elimination.

Still, I hope this picture will help you:

Image
2 x
Every man should plant a tree, build a house, and write a ZX Spectrum game.

Author of A Yankee in Iraq, a 50 fps shoot-’em-up—the first game to utilize the floating bus on the +2A/+3,
and zasm Z80 Assembler syntax highlighter.

User avatar
Muttley Black
Dizzy
Posts: 87
Joined: Wed Apr 03, 2019 2:31 pm

Re: Trying to fix my ZxSpectrum+

Post by Muttley Black » Mon Jul 01, 2019 9:11 pm

Hyuma wrote:
Mon Jul 01, 2019 7:12 pm
I think it should be connected to the pin 14 of IC7, but i'm waiting some confirm! :D
Yes. I confirm that.

Also, clean your work with isopropyl alcohol and toothbrush before you test the unit.
1 x

Hyuma
Berk
Posts: 34
Joined: Sat May 18, 2019 6:43 am

Re: Trying to fix my ZxSpectrum+

Post by Hyuma » Mon Jul 01, 2019 9:42 pm

yes, now next step will be buying rams and ZTXs
0 x

Hyuma
Berk
Posts: 34
Joined: Sat May 18, 2019 6:43 am

Re: Trying to fix my ZxSpectrum+

Post by Hyuma » Tue Jul 09, 2019 9:43 am

Time for some updates, 751 and 651 are in place!

Image

Image

Can i do some tests now? (I still don't have ram)
0 x

Post Reply