ZEsarUX-7.1

Struggling with Fuse or trying to find an emulator with a specific feature. Ask your questions here.
User avatar
g0blinish
Dizzy
Posts: 96
Joined: Sun Jun 17, 2018 1:54 pm

Re: ZEsarUX-7.1

Post by g0blinish » Thu Sep 27, 2018 3:42 pm

chernandezba wrote:
Mon Sep 24, 2018 6:47 pm
Which OS are you using?
If using Windows or Linux, try changing the QL keymap (on settings->hardware->keyboard)
windows 7
0 x

Pobulous
Berk
Posts: 14
Joined: Wed Nov 15, 2017 12:51 pm

Re: ZEsarUX-7.1

Post by Pobulous » Mon Oct 08, 2018 9:57 pm

With Gandalf Deluxe, the multicolour is off in the latest version 7.1 of ZEsarUX, on Windows 10 (1809 :shock: )
Using +2A configuration there are rolling colour lines near your starting position and on the right hand ladder.
Using 128K or +2, the multicolour is stable but there appear to be errors on the right hand ladder

ZXSpin doesn't have either of these problems.
0 x

chernandezba
Berk
Posts: 41
Joined: Tue Nov 28, 2017 7:39 am

Re: ZEsarUX-7.1

Post by chernandezba » Tue Oct 09, 2018 7:23 am

g0blinish wrote:
Thu Sep 27, 2018 3:42 pm
chernandezba wrote:
Mon Sep 24, 2018 6:47 pm
Which OS are you using?
If using Windows or Linux, try changing the QL keymap (on settings->hardware->keyboard)
windows 7
Sorry there are some problems mapping non "standard" keys (no standard 40 speccy keys) to QL and other systems. Mac OS X or Linux+framebuffer video doesn't have that problem
0 x

chernandezba
Berk
Posts: 41
Joined: Tue Nov 28, 2017 7:39 am

Re: ZEsarUX-7.1

Post by chernandezba » Tue Oct 09, 2018 7:24 am

Pobulous wrote:
Mon Oct 08, 2018 9:57 pm
With Gandalf Deluxe, the multicolour is off in the latest version 7.1 of ZEsarUX, on Windows 10 (1809 :shock: )
Using +2A configuration there are rolling colour lines near your starting position and on the right hand ladder.
Using 128K or +2, the multicolour is stable but there appear to be errors on the right hand ladder

Real video setting is always off by default, unless you enable it on configuration
About Gandalf and other nirvana-like games... yes, I know there are some attributes that are not in sync. In the future it will be fixed ;)
ZXSpin doesn't have either of these problems.
Well ZXSpin doesn't have lots of features that ZEsarUX does
0 x

Pobulous
Berk
Posts: 14
Joined: Wed Nov 15, 2017 12:51 pm

Re: ZEsarUX-7.1

Post by Pobulous » Tue Oct 09, 2018 4:30 pm

Thanks for the fast response 8-)

Yes I had Real video setting on - "off" was a bad choice of words, I just meant it was showing some issues.

I know that ZXSpin doesn't have all the features that ZEsarUX has, I was using ZXSpin for comparison to see if it was a bug in the game or with the emulation.

I know that there's some work being done combining multicolour with LCD scanlines - would be great to see that working in ZEsarUX.

It's a great emulator, and I love that you've implemented so many modern features.
0 x

chernandezba
Berk
Posts: 41
Joined: Tue Nov 28, 2017 7:39 am

Re: ZEsarUX-7.1

Post by chernandezba » Wed Oct 10, 2018 8:42 am

Pobulous wrote:
Tue Oct 09, 2018 4:30 pm


I know that there's some work being done combining multicolour with LCD scanlines - would be great to see that working in ZEsarUX.

It's a great emulator, and I love that you've implemented so many modern features.
Thanks :) Well scanlines are a concept that started on CRT, not just LCD. In fact, some other colour effects (scanlines or gigascreen) perform better on old CRT than on modern LCD.

Anyway, as I said, I will fix it in the future. It requires an almost complete rewrite of my scanlines codes and it's not easy. It will probable also use more cpu than now. So, meanwhile, I prefer to have these "glitches" on some attributes and have something to fix in the future ;)
0 x

Post Reply