Fuse for macOS 1.5.2 Released

Struggling with Fuse or trying to find an emulator with a specific feature. Ask your questions here.
Post Reply
User avatar
Fred
Berk
Posts: 38
Joined: Tue Feb 27, 2018 3:15 am

Fuse for macOS 1.5.2 Released

Post by Fred » Sun Apr 01, 2018 12:21 pm

A new version of Fuse for macOS has been released at the dedicated sourceforge project:

https://sourceforge.net/projects/fuse-for-macosx/

Note that this release requires Mac OS X 10.8+

Emulation core improvements:
  • Emulate ROM bug loading zero length blocks when using tape traps (ub880d).
Machine specific improvements:
  • Fix the format of double-sided +3 disks (Sergio Baldoví).
Miscellaneous improvements:
  • Spectrum reset is accelerated when auto-load is enabled and a file is loaded from the menu (Fredrick Meunier).
  • Add preferences for changing the auto-load mode (Fredrick Meunier).
0 x

User avatar
Ast A. Moore
Dynamite Dan
Posts: 1189
Joined: Mon Nov 13, 2017 3:16 pm

Re: Fuse for macOS 1.5.2 Released

Post by Ast A. Moore » Sun Apr 01, 2018 1:01 pm

Thanks, @Fred

There’s a bug, though. When “Auto-load media” and “Use tape traps” are enabled, Fuse disables all sounds. Brining up the Preferences window and closing it reenables them. Alternatively, sounds are reenabled after a certain time period.
0 x
Every man should plant a tree, build a house, and write a ZX Spectrum game.

Author of A Yankee in Iraq, a 50 fps shoot-’em-up—the first game to utilize the floating bus on the +2A/+3,
and zasm Z80 Assembler syntax highlighter.

User avatar
Fred
Berk
Posts: 38
Joined: Tue Feb 27, 2018 3:15 am

Re: Fuse for macOS 1.5.2 Released

Post by Fred » Sun Apr 01, 2018 1:09 pm

Sigh - thanks @Ast A. Moore, confirmed this issue. That's what I get for mostly using my computer with the sound muted :roll:

I'll have a look at what's going wrong over the next few days.
0 x

User avatar
Ast A. Moore
Dynamite Dan
Posts: 1189
Joined: Mon Nov 13, 2017 3:16 pm

Re: Fuse for macOS 1.5.2 Released

Post by Ast A. Moore » Sun Apr 01, 2018 1:13 pm

Fred wrote:
Sun Apr 01, 2018 1:09 pm
Sigh - thanks Ast A. Moore, confirmed this issue. That's what I get for mostly using my computer with the sound muted :roll:

I'll have a look at what's going wrong over the next few days.
No worries, @Fred! The good news is that you’ve replicated, so it’s not some obscure once-in-a-blue-moon condition.
0 x
Every man should plant a tree, build a house, and write a ZX Spectrum game.

Author of A Yankee in Iraq, a 50 fps shoot-’em-up—the first game to utilize the floating bus on the +2A/+3,
and zasm Z80 Assembler syntax highlighter.

Post Reply