SAM Coupé screenshot format

This is the place for general discussion and updates about the ZXDB Database. This forum is not specific to Spectrum Computing.

Moderator: druellan

User avatar
PeterJ
Site Admin
Posts: 2326
Joined: Thu Nov 09, 2017 7:19 pm
Location: Surrey, UK

Re: SAM Coupé screenshot format

Post by PeterJ »

Excellent @obo,

I'm glad I can now switch to your emulator. Thank you for doing this.

I use an outlook.com email address for new message alerts. I know they often go in people's junk folders.
0 x

obo
Berk
Posts: 26
Joined: Sat Sep 01, 2018 11:08 am
Location: Nottingham, UK
Contact:

Re: SAM Coupé screenshot format

Post by obo »

Stefan spotted that I'd attached the wrong binaries to the release, using those from 24th March instead of 24th May. Please re-download if you've grabbed the older files, as only the new version supports SSX.

It looks like my forum notifications are working now too :)
2 x

User avatar
moroz1999
Manic Miner
Posts: 233
Joined: Fri Mar 30, 2018 9:22 pm

Re: SAM Coupé screenshot format

Post by moroz1999 »

Thank you! That's a really great news, I will add a support of the format as soon as possible.
3 x

User avatar
moroz1999
Manic Miner
Posts: 233
Joined: Fri Mar 30, 2018 9:22 pm

Re: SAM Coupé screenshot format

Post by moroz1999 »

Please check github for an updated version of ZX-Image.
I've added support of mode3 and mode4 SSX files, others are to be implemented soon as well.

When I try to run the python script, I get the following problem:
f:\projects\ssxview-master>python ssxview.py mode2.ssx
File "ssxview.py", line 71
sys.exit(f"Invalid SSX file size ({size} bytes)")
^
SyntaxError: invalid syntax

What am I doing wrong? I've copied mode2.ssx from samples to same dir as python script located.
2 x

obo
Berk
Posts: 26
Joined: Sat Sep 01, 2018 11:08 am
Location: Nottingham, UK
Contact:

Re: SAM Coupé screenshot format

Post by obo »

Thanks for the updated zx-image, which I'll get set up soon.

It looks like it's choking on the f-string formatter in ssxview.py, which was added in Python 3.6. I'd best add that as a requirement :)
1 x

Post Reply