Comma search problem

This is the place for general discussion and updates about the ZXDB Database. This forum is not specific to Spectrum Computing.
User avatar
PeteProdge
Manic Miner
Posts: 249
Joined: Mon Nov 13, 2017 9:03 am

Comma search problem

Post by PeteProdge » Mon Apr 16, 2018 9:23 am

I, Of The Mask brings up no results.

I Of The Mask does bring up the game - I, of the Mask.
0 x

User avatar
Ast A. Moore
Manic Miner
Posts: 341
Joined: Mon Nov 13, 2017 3:16 pm

Re: Comma search problem

Post by Ast A. Moore » Mon Apr 16, 2018 9:28 am

Confirmed.
0 x
Every man should plant a tree, build a house, and write a ZX Spectrum game.

Author of A Yankee in Iraq, a 50 fps shoot-’em-up—the first game to utilize the floating bus on the +2A/+3,
and zasm Z80 Assembler syntax highlighter.

Kweepa
Dizzy
Posts: 85
Joined: Sat Feb 03, 2018 6:14 pm

Re: Comma search problem

Post by Kweepa » Mon Apr 16, 2018 2:03 pm

The forum search is also crap :)
"I of the Mask" returns 0 results.
"I, of the Mask" also returns 0 results.
0 x

User avatar
Einar Saukas
Manic Miner
Posts: 373
Joined: Wed Nov 15, 2017 2:48 pm

Re: Comma search problem

Post by Einar Saukas » Mon Apr 16, 2018 4:29 pm

PeteProdge wrote:
Mon Apr 16, 2018 9:23 am
I, Of The Mask brings up no results.

I Of The Mask does bring up the game - I, of the Mask.
The SC website needs to remove commas from title, author and publisher fields in advanced search, before searching them on ZXDB. The same applies to the text field in basic search.

@PeterJ can you please take a look at this?
0 x

User avatar
Einar Saukas
Manic Miner
Posts: 373
Joined: Wed Nov 15, 2017 2:48 pm

Re: Comma search problem

Post by Einar Saukas » Mon Apr 16, 2018 4:55 pm

Kweepa wrote:
Mon Apr 16, 2018 2:03 pm
The forum search is also crap :)
"I of the Mask" returns 0 results.
"I, of the Mask" also returns 0 results.
There's definitely something wrong there.

Apparently when you search for "I of the Mask", the forum considers that "I" and "the" are common words that must be excluded from search. So it tries to find an exact match for the remaining words "of Mask". Evidently it won't find anything this way.

If you select "search for any items" instead of "all items", then it works as expected.
1 x

Kweepa
Dizzy
Posts: 85
Joined: Sat Feb 03, 2018 6:14 pm

Re: Comma search problem

Post by Kweepa » Mon Apr 16, 2018 5:02 pm

Yeah, if it's going to do an exact match, it shouldn't exclude common words!
0 x

User avatar
PeterJ
Site Admin
Posts: 512
Joined: Thu Nov 09, 2017 7:19 pm
Location: Surrey, UK

Re: Comma search problem

Post by PeterJ » Mon Apr 16, 2018 7:32 pm

Kweepa wrote:
Mon Apr 16, 2018 2:03 pm
The forum search is also crap :)
"I of the Mask" returns 0 results.
"I, of the Mask" also returns 0 results.
I'm not sure I would says it's crap @Kweepa :-) I have looked at the admin side of phpBB and it looks like you can't change the search behaviour of the forum search. If any other phpBB user knows different please let me know.

Thanks as always for bringing these things to our attention.
0 x

User avatar
PeterJ
Site Admin
Posts: 512
Joined: Thu Nov 09, 2017 7:19 pm
Location: Surrey, UK

Re: Comma search problem

Post by PeterJ » Mon Apr 16, 2018 7:40 pm

Hi @PeteProdge

I, Of The Mask should now bring up results.

Thanks for letting us know.
1 x

User avatar
Einar Saukas
Manic Miner
Posts: 373
Joined: Wed Nov 15, 2017 2:48 pm

Re: Comma search problem

Post by Einar Saukas » Mon Apr 16, 2018 9:44 pm

PeterJ wrote:
Mon Apr 16, 2018 7:32 pm
Kweepa wrote:
Mon Apr 16, 2018 2:03 pm
The forum search is also crap :)
"I of the Mask" returns 0 results.
"I, of the Mask" also returns 0 results.
I'm not sure I would says it's crap @Kweepa :-) I have looked at the admin side of phpBB and it looks like you can't change the search behaviour of the forum search. If any other phpBB user knows different please let me know.
If this is a forum software bug and there's no available fix yet, perhaps you can simply change it to choose "search for any items" as default?
0 x

User avatar
PeterJ
Site Admin
Posts: 512
Joined: Thu Nov 09, 2017 7:19 pm
Location: Surrey, UK

Re: Comma search problem

Post by PeterJ » Tue Apr 17, 2018 5:11 am

Hi @Einar Saukas

Having taken a look and checked on Google there seems to be no configuration options for search in the backend.

People will just need to change the search option if they don't first get results. I think the ignoring of common words is frequently done on search tools. The phpBB engine builds an index and looks for common words. I can rebuild the index but I don't think that would change anything.
0 x

Post Reply